iCEBreaker FPGA board issue?

Hello everybody

i got my iCEBreaker board and was trying out the examples.
The first example i tried was a modified version of WTFpga (without seg seg and dip switch).

  • A simple one which used the onboard push buttons and leds and this worked.

After that i soldered the connectors and then tested with the dip switch and 7 segment pmods. But its not working, Further the earlier program also is also not working.
When connected via the USB, the all the 4 green leds and the red led gets lit lightly, as seen below.

Any possibility of testing if the board is ok.?

thanks and regards

1 Like

Welcome to the iCEBreaker community.

When you received the iCEBreaker board and plugged it into power for the first time was it blinking?

If so then the board is very likely working totally fine.

What exact steps did you follow to install the toolchain, build your bitstream and everything else. You need to provide us with as much detailed information as you can including the operating system you are using as you can so we have a chance of giving you pointers.

I hope we can figure out what the problem is with your setup. :slight_smile:


One more thing. Which WTFpga guide are you using? You should use the icebreaker github organization repository:

Hi Piotr

Thank you for your reply. Its nice that you have come up with this opensource fpga board capable of running risc-v and similar cpus. :slight_smile:

When you received the iCEBreaker board and plugged it into power for the first time was it blinking?
If so then the board is very likely working totally fine.

Yes it was blinking the first time i plugged it in.
Further, i followed the instructions.
and installed the tool chain (

Since i had not soldered the pmod connectors, the wtfpga.v was modified to use only the
on board push button and leds,wtfpga.v

make && make prog when thru fine.
iceprog wtfpga.bin
cdone: low
cdone: low
flash ID: 0xEF 0x40 0x18 0x00
file size: 104090
erase 64kB sector at 0x000000…
erase 64kB sector at 0x010000…
cdone: low

And the leds were responding to button clicks.

After that i soldered the pmod connectors to interface with 7-Segment LED and DIP Switch,
And then i tried the wtfpga prog (modified as well as the original)
In both cases make, make prog went thru fine. but them the LEDs are glowing continuouslt and push buttons dont respond too,.

Would it be the case that the soldering connectors messed up things. (i checked voltages 5v. 3.3v etc they are coming to the pmod connectors). i also checked individual pin shorts etc. does not seem to be a problem

Any suggesting would be highly appreciated.

thanks and regards

Hi Esden

Thank you for the reply.

Like you mentioned, i used the wtfgpa from github (there was also a pdf of the manual)

thanks and regards

It is hard to say what might be wrong in your case.

You could try different examples to test if the Pmods are working right.

There is a 7-segment counter, blink shift count (that is part of the demo shipping with the board) as well as the final solution of the workshop that is known to work.

You could try those. You could also connect a multimeter, LED, oscilloscope or logic analyzer to the Pmod pins to see if they display things correctly. Based on your photo the 7Segment display does not even faintly light up, this is probably because the GPIO are configured but not driven correctly. Did you make sure you are driving the right Pmod output? Check against the workshop solution to see if that is the issue.

Good luck. :slight_smile:

Hi Piotr

Thank you for your reply.

The WTfpga i tried is the original one. May be during the soldering i might have messed some thing.
I used the standard Goot 30W soldering iron. Initial there was some problem in the tip, and i did keep the hot iron for some time while soldering the PMOD connectors. I will check with oscilloscope. Might take a while.

Mean while i am placing an order for couple of the FPGA boards thru crownsupply.

Thanks once for your inputs.:slight_smile:

best regards

I hope you can figure out what the issue is and what caused it at the end. Indeed it is good to have spare hardware to compare with. :slight_smile:

You can order through CrowdSupply as well as 1BitSquared USA and 1BitSquared Germany. All of them would work fine as sources. I think CrowdSupply is planning to start shipping next week. 1BitSquared has inventory now and we can ship immediately. :slight_smile:


Hi Piotr

Thanks for the reply. As you mentioned, when i have the extra boards, i could compare the signals.
The thing is upload of bitstream is going fine, but then fpga is not responding to button press etc.
BTW, what does the CRESET do? i have soldered the jumper and its open.

Regarding ordering of extra fpga boards, i did create a login account @1BitSquared and then when i proceeded to checkout, there was a message saying that this item doesnot ship to UAE. (some export restrictions).

So i have requested the crowdsupply folks to send me the fpga board alone.

Thanks again for your inputs. :slight_smile:

best regards